ACAPI_​ElemDifferenceGenerator_​GenerateDifference

It gives back the differencies between two states.

    GSErrCode  ACAPI_ElemDifferenceGenerator_GenerateDifference (
        API_ElemDifferenceGeneratorTypeID              type,
        const API_ElemDifferenceGeneratorState*        diffState1,
        const API_ElemDifferenceGeneratorState*        diffState2,
        API_ElemDifference&                            difference
    );

 

Parameters

type
[in] The element difference generator method type.
diffState1
[in] The first difference generator state.
diffState2
[in] The second difference generator state.
difference
[out] The result of the difference generator.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The diffState1 or diffState2 is nullptr, or has wrong input parameters.
APIERR_GENERAL
There is no current plan open.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Plan_Dump test add-on.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

API Functions