ACAPI_​ElemDifferenceGenerator_​GetState

Classifies an element.

    GSErrCode  ACAPI_ElemDifferenceGenerator_GetState (
        API_ElemDifferenceGeneratorTypeID        type,
        API_ElemDifferenceGeneratorState*        diffGeneratorState
    )

 

Parameters

type
[in] The element difference generator methode type.
diffState1
[in/out] The difference generator state.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The diffGeneratorState is nullptr, or has wrong input parameters.
APIERR_GENERAL
There is no current plan open.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Plan_Dump test add-on.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

Element difference,
API Functions