Attaches an observer to the given element.
GSErrCode ACAPI_Element_AttachObserver ( const API_Guid& elemGuid, GSFlags notifyFlags = 0 );
Parameters
- elemGuid
- [in] Identifies the element to attach the observer to.
- notifyFlags
- [in] Defines the behavior of the attached observer in certain database operations.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- The referenced element cannot be found in the database.
For other common API errors see the API Errors document.
Remarks
This function can be used to track changes in an element. After attaching the observer, the installed APIElementEventHandlerProc
will be called with the appropriate notifications.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_DetachObserver
APIElementEventHandlerProc
Notification Manager, API Functions