ACAPI_​Element_​ChangeMore

Modifies a number of elements in the current database.

    GSErrCode  ACAPI_Element_ChangeMore (
        GS::Array<API_Guid>&       elemGuids,
        const API_Element*         defPars,
        const API_ElementMemo*     defMemo,
        const API_Element*         mask,
        UInt64                     memoMask,
        bool                       withdel
    );

 

Parameters

elemGuids
[in/out] This parameter identifies the elements to be modified.
defPars
[in] The parameters of the new element.
defMemo
[in] The memo of the new element. (Only if needed.)
mask
[in] The mask of the new element.
memoMask
[in] The memo mask of the new element. (Only if needed.)
withdel
[in] Delete the original instances of elements, or keep them and create new ones

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE
The current database should be the floor plan a section/elevation a detail a layout or a master layout.
APIERR_BADPARS
The passed defParams parameter is nullptr,
or the element is grouped and suspend group mode is OFF, or the element type is invalid or not supported by the server application.
APIERR_BADID
The element reference is invalid (guid)
APIERR_DELETED
The element does not exist in the database
APIERR_NOTMINE,
APIERR_LOCKEDLAY,
APIERR_HIDDENLAY,
APIERR_NOTEDITABLE
The referenced element cannot be modified

For other common API errors see the API Errors document.

 

Remarks

This function is an extension of ACAPI_Element_Change to modify more elements at the same time.

 

Requirements

Version: API 10 or later
Header: ACAPinc.h

 

See Also

API_Element
API_ElementMemo
ACAPI_Element_Change
ACAPI_Element_ChangeMemo
ACAPI_Element_ChangeParameters
ACAPI_Element_Edit
ACAPI_DisposeElemMemoHdls
Element Manager
API Functions