ACAPI_​Element_​DeleteUserData

Removes the user data attached to the specified element.

    GSErrCode  ACAPI_Element_DeleteUserData (
        API_Elem_Head*     elemHead
    );

 

Parameters

elemHead
[in] Identifies the element the user data is attached to.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The element does not contain any user data assigned by this add-on.
APIERR_BADPLATFORMSIGN
The platformsign field in the user data is invalid.
APIERR_BADID
The passed type is not correct.
 

For other common API errors see the API Errors document.

 

Remarks

You can remove the user data that is no longer needed and is attached to an element with this function.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SetUserData, API Functions