ACAPI_​Element_​DrwGuidToLinkId

Converts a Drawing’s guid to its link unique ID equivalent in a pre-12.0 plan file.

    Int32  ACAPI_Element_DrwGuidToLinkId (
        API_Guid     drwGuid
    );

 

Parameters

drwGuid
[in] The guid of the drawing.

 

Return Values

The link unique ID. Used in Archicad 11 and older vesrions.

Remarks

The linkUId member of API_DrawingType strucure is not used anymore. APIDb_GetDrawingLinkID function requires the drawing’s guid instead of linkUId.
Archicad started saving a version 11.0 file, and conversion of drawings’API_Guids stored in user datas or modul datas may be necessary. Use this function to perform the conversion.

Requirements

Version: API 12.0 or later
Header: ACAPinc.h

 

See Also

API_Guid, API Functions