ACAPI_​Element_​GetClassificationInSystem

Retrieves a classification of an elem in a given classification system.

    GSErrCode  ACAPI_Element_GetClassificationInSystem (
        const API_Guid&             elemGuid,
        const API_Guid&             systemGuid,
        API_ClassificationItem&     item
    );

 

Parameters

elemGuid
[in] The guid of the element.
systemGuid
[in] The guid of the classification system in which the classification item should be retrieved.
item
[out] The retrieved classification item (empty with null guid if the elem doesn’t have a classification in the given system).

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element or systemGuid did not refer to a valid classification system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions