ACAPI_​Element_​GetClassificationItems

Retrieves all of the classifications of an element.

    GSErrCode  ACAPI_Element_GetClassificationItems (
        const API_Guid&                              elemGuid,
        GS::Array<GS::Pair<API_Guid, API_Guid>>&     systemItemPairs
    );

 

Parameters

elemGuid
[in] The guid of the element.
systemItemPairs
[out] A list of classification system and classification item guid pairs, that represent the element’s classifications.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions