ACAPI_​Element_​GetClassificationItemsDefault

Retrieves all of the classifications of a default elem.

    GSErrCode  ACAPI_Element_GetClassificationItemsDefault (
        const API_ElemType&                          type,
        GS::Array<GS::Pair<API_Guid, API_Guid>>&     systemItemPairs
    );

 

Parameters

type
[in] Type of the default element.
systemItemPairs
[out] A list of classification system and classification item guid pairs, that represent the element’s classifications.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The type did not refer to a valid default element.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions