Returns the collisions between two groups.
GSErrCode ACAPI_Element_GetCollisions ( const GS::Array<API_Guid>& guidSet1, const GS::Array<API_Guid>& guidSet2, GS::Array<GS::Pair<API_CollisionElem, API_CollisionElem>>& resultArray, const API_CollisionDetectionSettings& apiColDetSettings );
Parameters
- guidSet1
- [in] The first group of the comparison.
- guidSet2
- [in] The second group of the comparison.
- resultArray
- [out] The result array of the detected collisions.
- apiColDetSettings
- [in] Collisions detection settings.
Return Values
APIERR_GENERAL
- Couldn’t get the collisions.
For other common API errors see the API Errors document.
Remarks
This function is used to detect collisions between two groups. You can find an example for this function in the Element_Test addon.
Requirements
- Version: API 21 or later
- Header: ACAPinc.h