Returns general information on the given element.
GSErrCode ACAPI_Element_GetHeader ( API_Elem_Head* elementHead, UInt32 mask );
Parameters
- elementHead
- [in/out] On input, it identifies the element based on its GUID. On return, the other fields are filled.
- mask
- [in] Optional mask. Currently valid values are
0
andAPIElemMask_FloorPlan
. In the latter case, the elements in the floor plan database are counted directly, without changing the database first.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This is a fast version of ACAPI_Element_Get, where only the fields of the header are returned. There are many cases when you only need information (e.g. layer, story) contained in the element header, but in the past the server application had to convert the whole element.
Requirements
- Version: API 11 or later
- Header: ACAPinc.h