ACAPI_​Element_​GetIFCClassificationReferences

Get IFC classificationreferences of an element

    GSErrCode  ACAPI_Element_GetIFCClassificationReferences (
        const API_Guid&                                guid_Element,
        bool                                           storedOnly,
        GS::Array<API_IFCClassificationReference>*     classificationReferences
    );

 

Parameters

guid_Element 
[in] GUID of the element
storedOnly API 19 feature
[in] Get only the core data without the derived content, must be false is most cases
classificationReferences 
[out] IFC classificationreferences of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or classificationReferences is nullptr.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function returns the IFC classificationreferences of an element.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SetIFCClassificationReference
ACAPI_Element_RemoveIFCClassificationReference