ACAPI_​Element_​GetIFCIdentifier

Get IFC Identifier of an element

    GSErrCode  ACAPI_Element_GetIFCIdentifier (
        const API_Guid&                 elementID,
        API_Guid&                       archicadIFCID,
        API_Guid&                       externalIFCID
    );

 

Parameters

elementID
[in] GUID of the element
archicadIFCID
[out] Archicad IFC ID of the element
externalIFCID
[out] External IFC ID of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Invalid value passed in the elementID parameter.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function returns the IFC Identifier of an element. There are two type of identifiers:

  • Archicad IFC ID – during an IFC export this value will be written to GlobalId attribute and can be seen in IFC Manager.
  • External IFC ID – if the element is originally from IFC then it contains the GlobalId. If it isn’t then it is APINULLGuid. It can be seen in IFC Manager also.

Conversion from API_Guid to IFC Guid string (IfcGloballyUniqueId) can be done with ACAPI_IFC_APIGuidToIFCGuid.

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_GetElemListByIFCIdentifier
ACAPI_IFC_APIGuidToIFCGuid
ACAPI_IFC_IFCGuidToAPIGuid