ACAPI_​Element_​GetIFCProperties

Get IFC properties of an element

    GSErrCode  ACAPI_Element_GetIFCProperties (
        const API_Guid&                 guid_Element,
        bool                            storedOnly,
        GS::Array<API_IFCProperty>*     properties
    );

 

Parameters

guid_Element 
[in] GUID of the element
storedOnly API 19 feature
[in] Get only the core data without the derived content, must be false is most cases
properties 
[out] IFC properties of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or properties is nullptr.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function returns the IFC properties of an element.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SetIFCProperty
ACAPI_Element_RemoveIFCProperty