ACAPI_​Element_​GetIFCPropertyValuePrimitiveType

Get the primitive type of an IFC type.

    GSErrCode  ACAPI_Element_GetIFCPropertyValuePrimitiveType (
        const GS::UniString&                   valueType,
        API_IFCPropertyValuePrimitiveType*     primitiveType
    );

 

Parameters

valueType
[in] IFC type of the property value
primitiveType
[out] Primitive type of the IFC type, see API_IFCPropertyAnyValue for values.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the valueType parameter or primitiveType is nullptr.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function returns the primitive type of an IFC type, which can be applied on properties.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

API_IFCPropertyAnyValue