ACAPI_​Element_​GetIFCType

Get IFC type and IfcTypeObject IFC type of an element

    GSErrCode  ACAPI_Element_GetIFCType (
        const API_Guid&                 elementID,
        GS::UniString*                  ifcType,
        GS::UniString*                  typeObjectIFCType
    );

 

Parameters

elementID
[in] GUID of the element
ifcType
[out] IFC type of the element
typeObjectIFCType
[out] IFC type of the IfcTypeObject of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Invalid value passed in the elementID parameter.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h