ACAPI_​Element_​GetLinkFlags

Retrieves the link flags associated to the link between the two elements.

    GSErrCode  ACAPI_Element_GetLinkFlags (
        const API_Guid&  guid_linkFrom,
        const API_Guid&  guid_linkTo,
        GSFlags*         linkFlags
    );

 

Parameters

guid_linkFrom Changed in API 11
[in] Identifies the element to which the other element was linked.
guid_linkTo Changed in API 11
[in] Identifies the element which was linked to the first element.
linkFlags
[out] Returns the custom flags assigned to the link with ACAPI_Element_Link.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed linkFlags pointer is nullptr.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.

For other common API errors see the API Errors document.

 

Remarks

When you link an element to an other, you can also pass custom flags which are stored with the link in the database. With this function you can retrieve these flags.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_Link, ACAPI_Element_Unlink, ACAPI_Element_GetLinks,
API Functions