ACAPI_​Element_​GetLinks

Returns a list of elements linked to the given element.

    GSErrCode  ACAPI_Element_GetLinks (
        const API_Guid&        guid_linkFrom,
        GS::Array<API_Guid>*   guid_linkTo
    );

 

Parameters

guid_linkFrom Changed in API 11
[in] Identifies the element to which the other elements were linked.
guid_linkTo Changed in API 11
[out] Returns the GUIDs of the elements which were linked to the first element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed guid_linkTo pointer is nullptr.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.

For other common API errors see the API Errors document.

 

Remarks

The element links are not bidirectional, you always link one element to another. This function returns the list of elements linked to the element having the guid_linkFrom GUID.

Note that if this function is called in an unclosed undoable session, then it returns not only the existing links, but also the links which have been deleted in the current undoable session.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_Link, ACAPI_Element_Unlink, ACAPI_Element_GetLinkFlags,
API Functions