Get the merged elements of the given element in the array.
GSErrCode ACAPI_Element_Merge_GetMergedElements ( const API_Guid& guid_Element, GS::Array<API_Guid>* guid_MergedElements );
Parameters
- guid_Element
- [in] The element GUID.
- guid_MergedElements
- [out] Array of GUIDs of the elements are merged with the given element.
Return Values
NoError
- The function has completed with success.
APIERR_BADDATABASE
,APIERR_NOTMINE
- The function cannot operate on the current database.
APIERR_BADINDEX
- One or more of the passed IDs are invalid.
APIERR_BADPARS
- Invalid value passed in the
guid_Element
parameter. APIERR_BADELEMENTTYPE
- The given element is not construction element.
For other common API errors see the API Errors document.
Remarks
This function gets elements are merged with the given element.
Example
GSErrCode Do_GetMergedElements (const API_Guid& guid_Element) { GSErrCode err = NoError; GS::Array<API_Guid> guid_MergedElements; err = ACAPI_Element_Merge_GetMergedElements (guid_Element, &guid_MergedElements); if (err != NoError) return err; for (UIndex i = 0; i < guid_MergedElements.GetSize (); i++) { char str[256]; sprintf (str, " Element: %s is merged with Element: %s", (const char *) APIGuid2GSGuid (guid_Element).ToUniString ().ToCStr (), (const char *) APIGuid2GSGuid (guid_MergedElements [i]).ToUniString ().ToCStr ()); WriteReport (str); } return err; }
Requirements
- Version: API 18 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_Merge_Elements
ACAPI_Element_Merge_Remove
API Functions