ACAPI_​Element_​GetPropertiesDefault

Retrieves the specified property definitions with values.

    GSErrCode  ACAPI_Element_GetPropertiesDefault (
        API_ElemTypeID               typeID,
        API_ElemVariationID          variationID,
        GS::Array<API_Property>&     properties
    );

 

Parameters

typeID
[in] Type of the default element.
variationID
[in] The element variation that distinguishes the element kinds of the same type.
properties
[in] Specifies the properties to retrieve. They are identified through definition.guid.
[out] The definitions and values of the requested properties.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect typeID or variationID was specified.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetAllPropertyValues (API_ElemTypeID typeId, API_ElemVariationID variationID, GS::Array<API_PropertyValue>& values)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (typeId, variationID, API_PropertyDefinitionFilter_BuiltIn, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            API_Property property == {};
            property.definition = definitions[i];
            properties.Push (property);
        }

        error = ACAPI_Element_GetPropertiesDefault (typeId, variationID, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                if (properties[i].isDefault) {
                    values.Push (properties[i].definition.defaultValue);
                } else {
                    values.Push (properties[i].value);
                }
            }
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions