ACAPI_​Element_​GetPropertyDefinitionsDefault

Retrieves all of the property definitions that are available for an element default.

    GSErrCode  ACAPI_Element_GetPropertyDefinitionsDefault (
        API_ElemTypeID                         typeID,
        API_ElemVariationID                    variationID,
        GS::Array<API_PropertyDefinition>&     definitions
    );

 

Parameters

typeID
[in] Type of the default element.
variationID
[in] The element variation that distinguishes the element kinds of the same type.
definitions
[out] Array of property definitions that are available for a classification of the given element default.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect typeID or variationID was specified.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetPropertyDefinitionNames (API_ElemTypeID typeId, API_ElemVariationID variationID, GS::Array<GS::UniString>& names)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitionsDefault (typeId, variationID, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            names.Push(definitions[i].name);
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions