ACAPI_​Element_​GetPropertyDefinitionsOfDefaultElem

Retrieves all of the property definitions that are available for an element default.

    GSErrCode  ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (
        const API_ElemType&                    type,
        API_PropertyDefinitionFilter           filter,
        GS::Array<API_PropertyDefinition>&     definitions
    );

 

Parameters

type
[in] Type of the default element.
filter
[in] The property definition type to filter for.
definitions
[out] Array of property definitions that are available for a classification of the given element default.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect type was specified.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example



GSErrCode GetPropertyDefinitionNames (const API_ElemType& type, GS::Array<GS::UniString>& names)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (type, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            names.Push(definitions[i].name);
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions