ACAPI_​Element_​GetPropertyValuesOfDefaultElem

Retrieves the values of the specified property definitions.

    GSErrCode  ACAPI_Element_GetPropertyValuesOfDefaultElem (
        const API_ElemType&                          type,
        const GS::Array<API_PropertyDefinition>&     propertyDefinitions,
        GS::Array<API_Property>&                     properties
    );

 

Parameters

type
[in] Type of the default element.
propertyDefinitions
[in] The property definitions (identified by definition.guid) to get the values for.
properties
[out] The definitions and values of the requested properties.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect type was specified.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example



GSErrCode GetAllPropertyValues (const API_ElemType& type, GS::Array<API_PropertyValue>& values)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (type, API_PropertyDefinitionFilter_UserDefined, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        error = ACAPI_Element_GetPropertyValuesOfDefaultElem (type, definitions, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                if (properties[i].isDefault) {
                    values.Push (properties[i].definition.defaultValue);
                } else {
                    values.Push (properties[i].value);
                }
            }
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions