ACAPI_​Element_​GetSyTran

Obtains the transformation parameters of an actual instance of a library part.

    GSErrCode  ACAPI_Element_GetSyTran (
        const API_Elem_Head*     elemHead,
        API_SyTran*              syTran
    );

 

Parameters

elemHead 17
[in] Identifies the element. Its type should be API_WindowID, API_DoorID, API_ObjectID, API_LampID, or API_ZoneID.
syTran
[out] The function returns the transformation parameters here.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The syTran parameter was nullptr.
APIERR_BADID
The element reference is invalid; elemHead->guid.
APIERR_DELETED
The element does not exist in the database
APIERR_GENERAL
The element reference is invalid; elemHead->guid.

For other common API errors see the API Errors document.

 

Remarks

You can get the transformation parameters of an actual instance of a library part (type should be API_WindowID, API_DoorID, API_ObjectID, API_LampID, or API_ZoneID) with this function. The transformation parameters are not easy to calculate and keep up-to-date, this function helps you to obtain this information.

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_ElemTypeID, API_SyTran,
Element Manager, API Functions