ACAPI_​Element_​GuidToUnId

Converts an API_Guid to its unique ID equivalent in a pre-11.0 plan file.

(obsolete function, not used any more)

    UInt32  ACAPI_Element_GuidToUnId (
        API_Guid              elemGuid,
        API_DatabaseUnId*     databaseUnId
    );

 

Parameters

elemGuid
[in] The GUID of the element.
databaseUnId
[out] The database which contains the element. The parameter may be nullptr.

 

Return Values

The function returns the corresponding unique ID, or 0 on error.

 

Remarks

This function may only be called from the handler function of the APINotify_ConvertGuid project event. In any other case it returns 0.

 

Requirements

Version: API 11 or later
Header: ACAPinc.h

 

See Also

API_Guid, API_NotifyEventID, ACAPI_Notify_CatchProjectEvent,
API Functions