ACAPI_​Element_​IsPropertyDefinitionAvailable

Tells whether a property definition is available for an element.

    bool  ACAPI_Element_IsPropertyDefinitionAvailable (
        const API_Guid&     elemGuid,
        const API_Guid&     propertyGuid
    );

 

Parameters

elemGuid
[in] The element GUID to search for.
propertyGuid
[in] The property definition GUID to search for.

 

Return Values

true
The given property definition is available for the element.
false
The given property definition is not available for the element.

Example


GSErrCode GetAvailablePropertyDefinitions (const API_Guid& elemGuid, GS::Array<API_PropertyDefinition>& availableProperties)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); ++i) {
            if (ACAPI_Element_IsPropertyDefinitionAvailable (elemGuid, definitions[i].guid)) {
                availableProperties.Push (definitions[i]);
            }
        }
    }
    return error;
}
        

Note: this example function is identical to calling ACAPI_Element_GetPropertyDefinitions, and you should use it if you need this functionality.

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions