Tells whether the value of the property can be modified for the specified tool default.
bool ACAPI_Element_IsPropertyDefinitionValueEditableDefault ( const API_ElemType& type, const API_Guid& propertyGuid );
Parameters
- type
- [in] Type of the default element.
- propertyGuid
- [in] The property definition GUID to search for.
Return Values
true
- The value of the property can be modified.
false
- The value of the property can not be modified. For example, it is a read-only property, or a User Defined property with expression, which has cyclic property references.
Remarks
From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.
Example
GSErrCode GetAvailablePropertyDefinitions (const API_ElemType& type, GS::Array<API_PropertyDefinition>& editableProperties) { GS::Array<API_PropertyDefinition> definitions; GSErrCode error = ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (type, API_PropertyDefinitionFilter_UserDefined, definitions); if (error == NoError) { for (UInt32 i = 0; i < definitions.GetSize (); ++i) { if (ACAPI_Element_IsPropertyDefinitionValueEditableDefault (type, definitions[i].guid)) { editableProperties.Push (definitions[i]); } } } return error; }
Requirements
- Version: API 22 or later
- Header: ACAPinc.h