Converts a drawing link unique ID to Drawing’s guid
.
API_Guid ACAPI_Element_LinkIdToDrwGuid ( Int32 linkId );
Parameters
- linkId
- [in] Drawing link unique ID. Used in Archicad 11 and previous versions.
Return Values
The guid
of the drawing.
Remarks
The linkUId
member of API_DrawingType strucure is not used anymore. APIDb_GetDrawingLinkID function requires the drawing’s guid instead of linkUId
.
If an old (Archicad 11 or older) project file was opened, and conversion of linkUId
s stored in user datas or module datas may be necessary. You are able to perform the conversion via this function.
Requirements
- Version: API 12.0 or later
- Header: ACAPinc.h