Check the mask for one element parameter.
ACAPI_ELEMENT_MASK_CHECK ( API_Element rec void typ void varnam );
Parameters
- rec
- [in] API_Element structure to set.
- typ
- [in] Name of structure (element type) mask is going to be used on.
- varnam
- [in] Name of the member of the structure you want to change using the mask.
Remarks
Check if the given parameter (varnam) is activated (not 0) in the mask (rec).
Example
if (mask != nullptr) { if (!ACAPI_ELEMENT_MASK_CHECK ((*mask), API_Elem_Head, layer)) ACAPI_ELEMENT_MASK_SET ((*mask), API_Elem_Head, layer); } element.header.layer = 27; err = ACAPI_Element_ChangeDefaults (&element, nullptr, &mask);
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API Functions,
ACAPI_ELEMENT_MASK_SET,
ACAPI_ELEMENT_MASK_SETFULL,
ACAPI_ELEMENT_MASK_CLEAR1,
ACAPI_ELEMENT_MASK_CLEAR,
ACAPI_Element_ChangeDefaultsExt