ACAPI_​ELEMENT_​QUANTITY_​MASK_​CHECK

Check the mask for one element parameter.

    ACAPI_ELEMENT_QUANTITY_MASK_CHECK (
        API_QuantitiesMask  rec
        void  typ
        void  varnam
    );

 

Parameters

rec
[in] API_QuantitiesMask structured mask to check.
typ
[in] Name of the member of the API_ElementQuantityMask structure mask is going to be used on.
varnam
[in] Name of the member of the typ structure you want to change using the mask.

 

Remarks

Check if the given parameter (varnam) is activated (not 0) in the mask (rec).

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API Functions,
ACAPI_ELEMENT_QUANTITY_MASK_SET,
ACAPI_ELEMENT_QUANTITY_MASK_SETFULL,
ACAPI_ELEMENT_QUANTITY_MASK_CLEAR,
API_QuantitiesMask,
API_ElementQuantityMask