Remove IFC property of an element
GSErrCode ACAPI_Element_RemoveIFCProperty ( const API_Guid& guid_Element, const API_IFCProperty& property );
Parameters
- guid_Element
- [in] GUID of the element
- property
- [in] IFC property to remove.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Invalid value passed in the
guid_Element
parameter orproperty
is not correct. APIERR_MODULNOTINSTALLED
- IFC add-on is not present.
For other common API errors see the API Errors document.
Remarks
If a property with the given property name and propertyset name exists for the element, this function will remove it.
If a property is not editable on the user interface, cannot be removed.
For a successful removal, the property.head
must be set correctly explained in the API_IFCPropertyHead structure.
The model may contain GDL objects with APPLICATION_QUERYs which display IFC data. It is the developer’s responsability to refresh the views after modifying IFC data through API functions. See: ACAPI_Automation – APIDo_RebuildID function.
Requirements
- Version: API 16 or later
- Header: ACAPinc.h