ACAPI_​Element_​SetIFCAttribute

Set IFC attribute of an element

    GSErrCode  ACAPI_Element_SetIFCAttribute (
        const API_Guid&             guid_Element,
        const API_IFCAttribute&     attribute
    );

 

Parameters

guid_Element
[in] GUID of the element
attribute
[in] IFC attribute to modify.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or attribute is not correct.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function sets the IFC attribute of an element.
If an attribute with the given name and type exists for the element, this command will change it.
If an attribute is not editable on the user interface, must not be changed.
For a successful change, the attribute must be set correctly explained in the API_IFCAttribute structure.
The model may contain GDL objects with APPLICATION_QUERYs which display IFC data. It is the developer’s responsability to refresh the views after modifying IFC data through API functions. See: ACAPI_Automation – APIDo_RebuildID function.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_GetIFCAttributes