ACAPI_​Element_​SetProperties

Sets the specified properties for the given values on an element.

    GSErrCode  ACAPI_Element_SetProperties (
        const API_Guid&                    elemGuid,
        const GS::Array<API_Property>&     properties
    );

 

Parameters

elemGuid
[in] The element GUID to search for.
properties
[in] Specifies the properties to be set.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element.
APIERR_NOACCESSRIGHT
The current user does not have the right to modify the properties of the specified element on a teamwork server.
APIERR_READONLY
Tried to modify a read-only property (for example a property coming from a hotlink).
APIERR_BADPROPERTY
The property definition is not available for the given element.

For other common API errors see the API Errors document.

 

Example



GSErrCode SetAllPropertyValuesToDefault (const API_Guid& elemGuid)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitions (elemGuid, API_PropertyDefinitionFilter_UserDefined, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        error = ACAPI_Element_GetPropertyValues (elemGuid, definitions, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                properties[i].isDefault = true;
            }
            error = ACAPI_Element_SetProperties (elemGuid, properties);
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions