ACAPI_​Element_​SetPropertiesOfDefaultElem

Sets the specified properties for the given values on an element default.

    GSErrCode  ACAPI_Element_SetPropertiesOfDefaultElem (
        const API_ElemType&                type,
        const GS::Array<API_Property>&     properties
    );

 

Parameters

type
[in] Type of the default element.
properties
[in] Specifies the properties to be set.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Incorrect type was specified or one of the property definitions’ guid did not refer to a valid object.
APIERR_NOACCESSRIGHT
The current user does not have the right to modify the properties of the specified element on a teamwork server.
APIERR_READONLY
Tried to modify a read-only property (for example a property coming from a hotlink).
APIERR_BADPROPERTY
The property definition is not available for the given element.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example



GSErrCode SetAllPropertyValuesToDefault (const API_ElemType& type)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitionsOfDefaultElem (type, API_PropertyDefinitionFilter_UserDefined, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        error = ACAPI_Element_GetPropertyValuesOfDefaultElem (type, definitions, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                properties[i].isDefault = true;
            }
            error = ACAPI_Element_SetPropertiesOfDefaultElem (type, properties);
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions