ACAPI_​Element_​SolidLink_​GetOperation

Retrieves the operation code of a Solid Operation Link.

    GSErrCode  ACAPI_Element_SolidLink_GetOperation (
        API_Guid                  guid_Target,
        API_Guid                  guid_Operator,
        API_SolidOperationID*     operation
    );

 

Parameters

guid_Target Changed in API 11
[in] Identifies the target element.
guid_Operator Changed in API 11
[in] Identifies the operator element.
operation
[out] The type of the Solid Operation.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADPARS
The operation parameter is nullptr.
APIERR_LINKNOTEXIST
There is no Solid Link in the database between elements specified by guid_Target and guid_Operator.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the operation code of a Solid Operation Link defined between two construction elements.

 

Requirements

Version: API 4.2 or later
Header: ACAPinc.h

 

See Also

API_SolidOperationID
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetTargets
ACAPI_Element_SolidLink_GetOperators
API Functions