ACAPI_​Element_​SolidLink_​GetOperators

Retrieves the operator elements linked to a target element.

    GSErrCode  ACAPI_Element_SolidLink_GetOperators (
        API_Guid                 guid_Target,
        GS::Array<API_Guid>*     guid_Operators
    );

 

Parameters

guid_Target Changed in API 11
[in] The GUID of the target element.
guid_Operators Changed in API 23
[out] GUID list of the operator elements linked to the target element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADPARS
The guid_Operators parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves a list of operator elements associated with a given target element with Solid Operation Link.

 

Requirements

Version: API 4.2 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetTargets
API Functions