ACAPI_​Element_​SolidLink_​GetTime

Retrieves the creation time of a Solid Operation Link.

    GSErrCode  ACAPI_Element_SolidLink_GetTime (
        API_Guid     guid_Target,
        API_Guid     guid_Operator,
        GSTime*      linkTime,
        UInt32*      linkSubTime
    );

 

Parameters

guid_Target Changed in API 11
[in] Identifies the target element.
guid_Operator Changed in API 11
[in] Identifies the operator element.
linkTime
[out] Time of the link creation.
linkSubTime
[out] Auxiliary time parameter of the link creation.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADPARS
The linkTime or the linkSubTime parameter is nullptr.
APIERR_LINKNOTEXIST
There is no Solid Link in the database between elements specified by guid_Target and guid_Operator.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the creation time of a Solid Operation Link defined between two construction elements.

Since GSTime is a second-precise date-time format, the linkTime parameter of that type is not enough to order the Solid Operation Links by their creation time. However it is important to know which operation is to be performed prior to another, if there is more than one Solid Operations defined to a given element. That is the auxiliary linkSubTime for, which distinguishes the link creation time values within one second.

 

Requirements

Version: API 4.2 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetTargets
ACAPI_Element_SolidLink_GetOperators
API Functions