Discontinues a Solid Operation Link.
GSErrCode ACAPI_Element_SolidLink_Remove ( API_Guid guid_Target, API_Guid guid_Operator );
Parameters
- guid_Target
- [in] Identifies the target element.
- guid_Operator
- [in] Identifies the operator element.
Return Values
NoError
- The function has completed with success.
APIERR_NEEDSUNDOSCOPE
- The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADDATABASE
,APIERR_NOTMINE
- The function cannot operate on the current database.
APIERR_BADINDEX
- One or both of the passed IDs are invalid, or the two IDs are equal.
APIERR_LINKNOTEXIST
- There is no Solid Link in the database between elements specified by
guid_Target
andguid_Operator
. APIERR_REFUSEDPAR
- Hotlinked Solid Links cannot be removed.
For other common API errors see the API Errors document.
Remarks
This function removes the Solid Operation Link defined between two construction elements.
Requirements
- Version: API 4.2 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetTargets
ACAPI_Element_SolidLink_GetOperators
API Functions