ACAPI_​Element_​Trim_​Elements

Trim elements given in the array with Roof(s) and/or Shell(s) are contained in the array.

    GSErrCode  ACAPI_Element_Trim_Elements (
        const GS::Array<API_Guid>&     guid_ElementsToTrim
    );

 

Parameters

guid_ElementsToTrim
[in] Array of GUIDs of the elements to trim with shells and roofs are contained in this array.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADINDEX
One or more of the passed IDs are invalid.
APIERR_BADPARS
Invalid value passed in the guid_ElementsToTrim parameter.
APIERR_BADELEMENTTYPE
There is element in the array, which is not construction element type, or there is no Roof or Shell element in the array to trim with.

For other common API errors see the API Errors document.

 

Remarks

This function trims elements given in the array with Roof(s) and/or Shell(s) are contained in the array.

 

 

Requirements

Version: API 15 or later
Header: ACAPinc.h

 

See Also

API_TrimTypeID
ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_Remove
ACAPI_Element_Trim_GetTrimType
ACAPI_Element_Trim_GetTrimmedElements
ACAPI_Element_Trim_GetTrimmingElements
API Functions