ACAPI_​Element_​Trim_​ElementsWith

Trim elements given in the array with the given Roof or Shell with the type of trim.

    GSErrCode  ACAPI_Element_Trim_ElementsWith (
        const GS::Array<API_Guid>&     guid_ElementsToTrim,
        const API_Guid&                guid_Element,
        API_TrimTypeID                 trimType
    );

 

Parameters

guid_ElementsToTrim
[in] Array of GUIDs of the elements to trim with the given Shell or Roof.
guid_Element
[in] The trimming element GUID.
trimType
[in] The type of the trimming.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADINDEX
One or more of the passed IDs are invalid.
APIERR_BADPARS
Invalid value passed in the guid_ElementsToTrim parameter or invalid value passed in the trimType parameter.
APIERR_BADELEMENTTYPE
There is element in the array, which is not construction element type or the trimming element is not Roof or Shell.

For other common API errors see the API Errors document.

 

Remarks

This function trims elements given in the array with the given Roof or Shell.

 

 

Requirements

Version: API 15 or later
Header: ACAPinc.h

 

See Also

API_TrimTypeID
ACAPI_Element_Trim_Elements
ACAPI_Element_Trim_Remove
ACAPI_Element_Trim_GetTrimType
ACAPI_Element_Trim_GetTrimmedElements
ACAPI_Element_Trim_GetTrimmingElements
API Functions