ACAPI_​Element_​Trim_​GetTrimmingElements

Get the trimming elements of the given element in the array.

    GSErrCode  ACAPI_Element_Trim_GetTrimmingElements (
        const API_Guid&          guid_Element,
        GS::Array<API_Guid>*     guid_TrimmingElements
    );

 

Parameters

guid_Element
[in] The element GUID.
guid_TrimmingElements
[out] Array of GUIDs of the elements are trimming the given element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADINDEX
One or more of the passed IDs are invalid.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter.
APIERR_BADELEMENTTYPE
The given element is not construction element.

For other common API errors see the API Errors document.

 

Remarks

This function gets elements are trimming the given element.

 

 

Requirements

Version: API 15 or later
Header: ACAPinc.h

 

See Also

API_TrimTypeID
ACAPI_Element_Trim_Elements
ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_Remove
ACAPI_Element_Trim_GetTrimType
ACAPI_Element_Trim_GetTrimmedElements
API Functions