ACAPI_​Element_​Trim_​GetTrimType

Get the type of trimming connection between the given elements.

    GSErrCode  ACAPI_Element_Trim_GetTrimType (
        const API_Guid&     guid_Element1,
        const API_Guid&     guid_Element2,
        API_TrimTypeID*     trimType
    );

 

Parameters

guid_Element1
[in] The first element GUID.
guid_Element2
[in] The second element GUID.
trimType
[out] The type of the trimming.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADINDEX
One or more of the passed IDs are invalid.
APIERR_BADELEMENTTYPE
One of the elements is not construction element type or there is no given Roof or Shell.

For other common API errors see the API Errors document.

 

Remarks

This function gets the type of trimming connection between the elements.

 

 

Requirements

Version: API 15 or later
Header: ACAPinc.h

 

See Also

API_TrimTypeID
ACAPI_Element_Trim_Elements
ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_Remove
ACAPI_Element_Trim_GetTrimmedElements
ACAPI_Element_Trim_GetTrimmingElements
API Functions