ACAPI_​Element_​UnIdToGuid

Converts an old unique ID to the corresponding element’s API_Guid.

    API_Guid  ACAPI_Element_UnIdToGuid (
        API_DatabaseUnId     databaseUnId,
        UInt32               elemUnId
    );

 

Parameters

databaseUnId
[in] The database which contains the element.
elemUnId
[in] The old unique ID of the element.

 

Return Values

The function returns the corresponding API_Guid, or APINULLGuid (GS::NULLGuid) on error.

 

Remarks

This function may only be called from the handler function of the APINotify_ConvertUnId project event. In any other case it returns APINULLGuid.

 

Requirements

Version: API 11.01 or later
Header: ACAPinc.h

 

See Also

API_Guid, API_NotifyEventID, ACAPI_Notify_CatchProjectEvent,
API Functions