Removes the link from the second element to the first.
GSErrCode ACAPI_Element_Unlink ( const API_Guid& guid_linkFrom, const API_Guid& guid_linkTo );
Parameters
- guid_linkFrom
- [in] Identifies the element to which the other element is linked.
- guid_linkTo
- [in] Identifies the element which is linked to the first element.
Return Values
NoError
- The function has completed with success.
APIERR_BADDATABASE
,APIERR_NOTMINE
- The function cannot operate on the current database.
APIERR_NEEDSUNDOSCOPE
- The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_LINKNOTEXIST
- There isn’t any link from the second element to the first.
For other common API errors see the API Errors document.
Remarks
This element removes the link to the second element (identified by guid_linkTo
) from the element identified by guid_linkFrom
. See ACAPI_Element_Link for more details.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_Link, ACAPI_Element_GetLinks, ACAPI_Element_GetLinkFlags,
API Functions