ACAPI_​ElementGroup_​GetGroup

Returns the group unique ID of the given element.

    GSErrCode  ACAPI_ElementGroup_GetGroup (
        const API_Guid&    elemGuid
        API_Guid*          groupGuid
    );

 

Parameters

elemGuid 
[in] Unique ID of the element.
groupGuid 
[out] Unique ID of the group which contains the element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Passed element ID is invalid.
APIERR_BADPARS
Invalid value passed in the parameters.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get unique ID of a group for a grouped element.

 

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetRootGroup
ACAPI_ElementGroup_GetGroupedElems
ACAPI_ElementGroup_GetAllGroupedElems
API Functions