ACAPI_​ElementGroup_​GetRootGroup

Returns the top level group unique ID of a nested group element.

    GSErrCode  ACAPI_ElementGroup_GetRootGroup (
        const API_Guid&    elemGuid
        API_Guid*          rootGroupGuid
    );

 

Parameters

elemGuid 
[in] Unique ID of the element.
rootGroupGuid 
[out] Unique ID of the root group.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Passed element ID is invalid.
APIERR_BADPARS
Invalid value passed in the parameters.

For other common API errors see the API Errors document.

 

Remarks

This function is used to obtain the top level group of a nested group element. If the passed group is not part of another group, the function returns the passed group guid as main group guid.

 

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetGroup
ACAPI_ElementGroup_GetGroupedElems
ACAPI_ElementGroup_GetAllGroupedElems
API Functions