ACAPI_​ElementGroup_​GetUserData

Obtains the user data attached to an element group.

    GSErrCode  ACAPI_ElementGroup_GetUserData (
        const API_Guid&            groupGuid
        API_UserData*              userData
    );

 

Parameters

groupGuid 
[in] Unique ID of the element group.
userData 
[in/out] Pointer to the new user data.

 

Return Values

NoError
The function has completed with success, a new user data has attached to the element group.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADID
Passed groupGuid ID is invalid.
APIERR_BADPARS
One or more passed parameters are nullptr.
APIERR_NOUSERDATA
No user data attached with the gived signature.
APIERR_MEMFULL
Out of memory.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the user attached data from an element group. Use the ACAPI_ElementGroup_SetUserData functions to push data into the element group.

 

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

API_UserData
ACAPI_ElementGroup_SetUserData
ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetGroup
ACAPI_ElementGroup_GetRootGroup
ACAPI_ElementGroup_GetGroupedElems
ACAPI_ElementGroup_GetAllGroupedElems
API Functions