ACAPI_​ElementGroup_​SetUserData

Attaches the user data to the element group.

    GSErrCode  ACAPI_ElementGroup_SetUserData (
        const API_Guid&            groupGuid
        const API_UserData*        userData
    );

 

Parameters

groupGuid 
[in] Unique ID of the element group.
userData 
[in] Pointer to the new user data.

 

Return Values

NoError
The function has completed with success, a new user data has attached to the element group.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADID
Passed groupGuid ID is invalid.
APIERR_BADPARS
Passed groupGuid parameter is nullptr.
APIERR_BADPLATFORMSIGN
The given platform sign is invalid (out of range).
APIERR_MEMFULL
Out of memory.

For other common API errors see the API Errors document.

 

Remarks

This function is used to attach user data to an element group. Use the ACAPI_ElementGroup_GetUserData function to get data from the element group. Existing user data can be deleted by setting userData input parameter to nullptr.

Note that this function is not undoable.

The caller should allocate and deallocate the userData->dataHdl handle.

 

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

API_UserData
ACAPI_ElementGroup_GetUserData
ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetGroup
ACAPI_ElementGroup_GetRootGroup
ACAPI_ElementGroup_GetGroupedElems
ACAPI_ElementGroup_GetAllGroupedElems
API Functions