Makes a property definition unavailable for all of given elements.
GSErrCode ACAPI_ElementList_DeleteProperty ( const API_Guid& definitionGuid, const GS::Array<API_Guid>& elemGuids );
Parameters
- definitionGuid
- [in] The GUID of the definition to remove from the elements.
- elemGuids
- [in] The array of elements, that the property should not be available for.
Return Values
NoError
- The function has completed with success.
APIERR_NOACCESSRIGHT
- Do not have the right to modify a property definition on a teamwork server.
APIERR_BADID
- One of the
elemGuids
did not refer to a valid element.
For other common API errors see the API Errors document.
Example
For more detailed examples, please see the Property_Test add-on.GSErrCode DeleteIntegerPropetiesOfSelection (GS::Array<API_Guid> selectedElements) { GS::Array<API_PropertyDefinition> definitions; ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions); for (UIndex i = 0; i < definitions.GetSize (); ++i) { if (definitions[i].collectionType == API_PropertySingleCollectionType && definitions[i].valueType == API_PropertyIntegerValueType) { GSErrCode err = ACAPI_ElementList_DeleteProperty (definitions[i].guid, selectedElements)); if (err != NoError) { return err; } } } return NoError; }
Requirements
- Version: API 20 or later
- Header: ACAPinc.h