ACAPI_​ElementSet_​GetData

Retrieves the data of an existing element set.

    GSErrCode  ACAPI_ElementSet_GetData (
        API_Guid                 setGuid,
        GS::Array<API_Guid>*     elemGuids,
        API_UserData*            data
    );

 

Parameters

setGuid Changed in API 12
[in] The GUID that identifies the element set.
elemGuids Changed in API 12
[out] Pointer to the array of element GUIDs.
data
[out] User data assigned to the set.

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE
The function cannot operate on the current database.
APIERR_BADID
The setGuid parameter is invalid.
APIERR_NOTMINE
The element set referenced by setGuid is owned by another user.
APIERR_DELETED
The element set is already deleted.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the element GUID list and the attached user data of an element set created by ACAPI_ElementSet_Create. Both of the output parameters are optional, can be nullptr.

Remember to release the userdata.dataHdl handles when you don’t need it any more.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

API_UserData
ACAPI_ElementSet_Create
ACAPI_ElementSet_Delete
ACAPI_ElementSet_Identify
Element Set Manager
API Functions